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Integration Note

Atlona OmniStream products support AES67 audio which delivers high-performance LPCM audio streaming over
IP networks. The following outlines the procedure for receiving AES67 audio from an OmniStream encoder to the
Q-SYS Core. Both the Q-SYS Core and the encoder are assumed to be on the same VLAN. This integration note
uses Q-SYS Designer 7.2.1.

This document is divided into three sections and covers the following topics:

I. Configuring the PTP Domain and PTP Priority.
Il. Creating the AES67 Session.

Ill. Linking the Receiver Object.

Configuring the PTP Domain and PTP Priority

In order for AES67 to function properly, the PTP settings within both Q-SYS and OmniStream must be properly
configured. This first section covers PTP priority and PTP domain configuration.

1. Launch the Q-SYS Designer software.

2. Click File > Open and load the desired design file.

[CD OmniStream-gsys - Q-SYS Designer [7.2.1] = =R
File | Edit View Tools Help
New Design Ctrl+N - > %:'
k=1
Open Cirl+0 = Schematic Elements £
5
Open Sample Design Ctrl+Shift+0 Graphic Tools
[T+
Save Cirl+§ g
Search gl
Save As Ctrl+Shift+S |
Components
I &1 Audio Components
Check Design... Shift+F6 | & Control Components
- B Secripting Components
Save to Core & Run s = Ve & T
I & Layout
Load from Core 8 Connect » | &3 UJ Buttons
Emulate F6 Plugins k=]
Disconnect F7 I & User
Recently Opened Designs... b Open Asset Manager
to download Plugins
Design Properties... _——————
User Components EEE
Preferences...
. Drag Schematic
Elements here to

create a Component.

Schematic Pages

User Control Interfaces

3. Click File > Design Properties. The Design Properties dialog will

. i B

be displayed. Design Properties
PTPv2 Domain Default (0) k -
By default, Q-SYS uses 0 for the PTPv2 Domain and the PTP PP Priority 5 -

Qo prese

Priority is set to 100. If a different domain is desired, click the
PTPv2 Domain drop-down list and select the desired range.

Consult with an IT administrator or Q-SYS documentation for PTPv2 DSCP Value (46 v
assistance. Audio DSCP Value |34 :
Camera DSCP Value |26 -

OK | l Cancel l
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PTP Domain value and PTP Priority

In general, a smaller PTP priority value will result in a higher probability for the device to become the PTP
Grandmaster (GM) clock. If Q-SYS will be the PTP GM, then make sure that the PTP priority on Q-SYS has a
lower PTP Grandmaster priority value than OmniStream.

If the Q-SYS Core has become the PTP GM, then the PTP priority of the Q-SYS should be below 128. Note that
OmniStream devices use 128 as the default PTP priority value.

PTP GM election will only occur if both Q-SYS and the OmniStream device are in the same PTP domain.

4. Click File > Save to Core & Run to push the design file to the Q-SYS Core.

5. Launch a web browser and enter the IP address of AMS.

of the desired encoder, and provide the correct login credentials. The default login credentials are:

o NOTE: OmniStream provides a built-in web server. If AMS is not available, then enter the IP address
admin (username), Atlona (password).

6. Enter the required AMS login credentials.

7. Click the Login button.

8. Click the desired encoder, within the AMS software. In this example, the AT-OMNI-112 dual-channel encoder is
being selected.

Device List 1 H
AMS Device List SCAN NETWORK a
o
! ~ Tt NAME MODEL P MAC ADDRESS FIRMWARE UPDATE SITE BUILDING
& AT-OMNI-112 AT-OMNI-112 10.20.200.123 B8:98B0O.0T:ASTF 122 Upto date 1 Building 1 Large Conference -
] O
" Building 1 ~
) AT-OMNI-121 AT-OMNI12 0.20200.139 0004:A5:21:0F:4 22 Upto date Building 1 La
&
& Lo Conferencern -~
[ ] OMN Up to date Building 1 Lai
¥ ATOMNI-T12

P Up to date uilding 1 [k
# ATOMNI122 ) ATHDVS200-TX ATHDVS-200TX CHECK (& Building 1 La
® ATOMNI5121

® THDVS-200-RX HD R BO0014EC CHECK (&

Group
[ ) CHECK (&
# ATHDVS-200-TX 1 ) CHECK (&
CHECK
¥ ATHOVS200.RX 1 C G
® CHECK (&

o

@ oo ° Upto date
[ ] 122 @

9. Click PTP in the top menu bar.

ENCODING ALARMS

NETWORK

SERIAL SESSION

DEVICE INFO

eth2

PTP Menu S
Interface Inters
eth1 eth2
Dormain Numbe: Domain Numbe:

0 0
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The OmniStream interface that is connected to the network, will participate in the PTP GM clock election
process. In this case, eth1 is connected and is noted by a green indicator, next to Is GM Present, shown below.

DEVICE INFO INPUT ENCODING SERIAL SESSION LOGO TEXT ALARMS NETWORK PTP
Interface Interface
eth1 eth2
Domain Nurmber Dornain Numbe
0 0
Is GM Present
Priority 1 Priority 1
128 128
Priority 2 Priority 2
128 128
Is GM Present [ ] Is GM Present ®
GM Identity GM Identity
70:54:02:FF:FE:C4:A5:BE B8:98:B0:FFFE0T:AS80
Master Offsel Master Offset
94 0

10. Verify that the MAC address of the Q-SYS Core is listed in the GM Identity field, within AMS, by performing the
following steps:

a. Click Tools > Show Q-SYS Configurator...
b. Click the core unit, under the Cores Pane. In this example, the Core 250i is selected.

c. Locate the MAC address of the Q-SYS Core in the pane, to the right.

) Omnistream-qsys - Q-SYS Designer [7.21]
File Edit View Tools Help
‘81 Core-Ationa

« | [JPrage1 Q-SYS Configurator X -

Design Elements

Inventory bagrP Lo Core-Atlonz =
4 Default Location [ Core 250i : core-atlona Firmware Version 721
b [®: Core 250i : Core-Atlona Design OmniStream-gsys ( Running )
b AESGT RX : QSYS-AESE7-RX Design Uptime 7 Days 6 Hours 23 Minutes 6 Secands
b AES67TX : QSYS-AESG7-TX Hardware ID. 3-646A4946D3DIAGBECBAIDOOFOBIBCTY
b 4, Softphone : Sofiphone-1 Select the Q-SYS Core
Netw
Slot A Blank
Slot 8 E
Sotc ‘ Q-SYS Core MAC Address
Slot D Blank
Slot E Mic/Line In - Std.
Slot F Blank
Slot G Dataport Out
SlotH Line Out
LAN A MAC : 70:54:02:G4:A5.8E

Wired To : 04:13:4e:58:<7:e8 : on 16
Mode : | Auto =

Schematic Pages Link Speed : 1000Mbg

1P Address : | 10.20.200.110

User Control Interfaces Net Mask: | 255.255.255.0 Gateway : | 10.20200.2

. Static Routes +

d. Compare this MAC address with the MAC address in the GM Identity field, within AMS. These MAC
addresses should be the same. If they are not, then another device on the network, which has a has a lower
PTP priority, is being used as the GM. Refer to the illustration on the next page.
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DEVICE INFO ENCODING SERIAL SESSION ALARMS NETWORK
Interface Interface
ethl
Q-SYS Core MAC Address

Domain Number Domain Number
0 0

Siot B Blank
Priority 1
128 Slot C Blank

Slot D Blank
Priotity 2 SlotE Mic/Line In - Std.
128 SlotF Blank
|= GM Present Y Slot G Dataport Out

SlotH Line Out
GM Identity LAN A MAGC : 70:54.02:C4:A5:BE
B ’ Wired To: ad:13:4e:58:c7:¢8 . on 16
70:54:D2:FF:FE:C4:A5:BE Link Speed : 1000Mbg Mode : |Auto -

IP Address : | 10.20.200.110 Net Mask : | 255.255.255.0 Gateway: | 10.20.200.2
Master Offsel
Static Routes +

94

Creating the AES67 Session

This next section covers creating the AES67 Session on the OmniStream encoder. A session is a class-D multicast
IP address that is assigned to a stream.

1. Verify that a source is connected to the HDMI input of the OmniStream encoder. For this example, the same
laptop that is running the Q-SYS Designer is connected to a dual-channel encoder (AT-OMNI-112) on HDMI IN 1.

2. Click SESSION in the top menu bar.

3. Scroll down and locate Session 3. For this tutorial, Session 3 is being used. However, another session, such as
Session 1, could also be selected. Refer to the OmniStream User Manual for more information on sessions.

4. Click the Interface drop-down list and select the correct interface: eth1 or eth2. In this example, an Ethernet
cable is connected from the ETHERNET 1 port on the encoder to the network. Therefore, eth1 is selected.

»

to network

from source

HDMI INZ— EEE———— [N

1
AT-OMNI-112

Marme

session3

Interface

eth E
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5. Click the SAP toggle switch to enable it. When enabled, the SAP toggle switch will be green. This feature must
be enabled to allow the device to announce itself on the network. Refer to the illustration on the next page.

6. Enter the stream name in the Name field. In this example, “laptop” is used. This name will be used to identify

the AES67 stream, within the Q-SYS Designer.

SAP

Interval

10 Name of stream

Marme

laptop

4

7. Click the Source drop-down list and select the HDMI input which is used for the audio source. In step 1 (on the
previous page), the source was connected to the HDMI IN 1 port on the encoder. Therefore, HDMI 1 is selected

as the source.

8. Continue scrolling down to the Audio section, and click the Enable AES67 toggle switch. When enabled, the

toggle switch will be green.
9. Click the Enable Audio toggle switch to enable it. When enabled, the toggle switch will be green.

10. Enter the destination multicast IP address for the audio in the Destination IP Address field.

HDMI input used to connect to source

Audio:

Enable AES
o

—Ource

HOMI

Enable AES&T

Dawnrmizing

MNane

Enable Audio AES67 audio multicast address

Destination IP Address

239.69.1.7

11. Click the SAVE button, at the bottom of the Session 3 window group.

Not Used

OmniStream
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Linking the Receiver Object

The final step is to link the receiver object, within Q-SYS Designer, to the AES67 stream from the OmniStream
encoder.

1. Return to the Q-SYS Designer. Under the Design Elements pane, the AES67 receiver (RX) component may be
highlighted in red, indicating that no audio stream has been assigned to the receiver object.

2. Double-click the AES67 Receiver object, in the schematic. The AES67 Receiver object properties window will

be displayed.
-3 OmniStream-qsys - Q-SVS Designer [7.21] =8 FT
File Edit View Tools Help
@: Care-Atlona
& [Pagel x -
Design Elements -
Inventory b a3 P
4 Default Location = ‘ = = = \'m i
Mic/Line In 5td. ms i u
b (@) Core 250i : Core-Atlona jCore 9 B coicie 8 Bpllixer
) SletE le) Echo i
b AES67 RX : QSYS-AES67-RX s
b AES67 TX : QSYS-AFS67-TX
b Y, Softphone : Softphone-1
Status/Control
Softphone-1
VOIP In

Softphone-1

m

Sterea
Gain

AES67 Transmitter
= Mixer 2x3 ' QsYs-AES67-TX

—

AES67 Receiver object

- AES67 Receiver @
Schematic Pages QsYs-AES67-gx ©
User Control Interfaces

Snapshots .

Named Controls

Inspector « [ i ] b 10% 3

3. Click the Stream Name drop-down list and select the “laptop”. This is the name of the stream which was
assigned in the OmniStream encoder, within AMS. Note that if additional OmniStream AES67 session streams
were created, they would be available in this drop-down list.

Note the message in the Status window: Fault - Invalid SDP. This indicates that no source is connected.
Always make sure that a valid stream is selected, from the Stream Name drop-down list.

Inventory AT p Stream ‘ Details |
4 Deffult Location Channel e 3 = e \;ﬁut
b (@) Core 250i : Core-Atlona [ — S
b AES67 RX : QSYS-AESG7-RX ! 2 7]

-
P AESGT TX : QSYS-AES67-TX AESET

b %, Softphone : Sofiphone-1

Indicates no source is connected

Peak Input Level
(dBFS)

-120dB | -120dB

m

L5

Digital f invert | (D
Mut: % AES67 Transmitter
e | -
Gain < —
Status v

Connection
Schematic Pages [
Enable [[ensie )
User Control Interfaces
[ stream Name | session 1/
i Network Rx Buffer [ —
Named Controls Interface lastop .
Inspector . session’ v 120% 3

OmniStream 8
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Verify the AES67 audio stream, between the OmniStream Encoder and Q-SYS, by opening an audio player on
the laptop and selecting an audio file. The Peak Input Level indicators should show that audio is now being
received from the OmniStream encoder to the Q-SYS Core.

[ Omnistream-qsys - Q-5¥5 Designer [7.21] = = |
Fle Edit View Taols Help
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1 2 B
b AESGT RX: QSYS-AES67-RX

AES67 —
b AES6T TX: QSYS-AES67-TX ,_f—

b %, Softphone : Softphone-1
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_
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Close the Receiver object property window. This design shows the AES67 stream name, below the AES67
Receiver object. Note that not all designs will display the AES67 stream below the AES67 Receiver object.
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